Subscribed unsubscribe Subscribe Subscribe

hasen's tech life

Twitter: @hasen

Bitbucketなどで削除したリモートのブランチを反映する.

Git

# Bitbucketなどで削除したリモートのブランチを反映する.

$ git branch -a
> remotes/origin/aaa
> remotes/origin/bbb
> remotes/origin/ccc
> remotes/origin/ddd
> ... (省略)
$ git fetch -p
> ... (省略)
$ git branch -a
> remotes/origin/ccc
> remotes/origin/ddd

composer installでエラーが出たので対応した.zmqのプラグインがなかった.

PHP Composer zmq

# composer installでエラーが出たので対応した.zmqのプラグインがなかった.

$ composer install --no-scripts
> You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
> Loading composer repositories with package information
> Installing dependencies (including require-dev) from lock file
> Your requirements could not be resolved to an installable set of packages.

> Problem 1
> - react/zmq v0.3.0 requires ext-zmq * -> the requested PHP extension zmq is missing from your system.
> - react/zmq v0.3.0 requires ext-zmq * -> the requested PHP extension zmq is missing from your system.
> - Installation request for react/zmq v0.3.0 -> satisfiable by react/zmq[v0.3.0].

$ brew unlink php71
$ brew link php56
$ php artisan optimize

HomebrewでMySQLをupgradeした時に実行しておくコマンド.

Homebrew MySQL

# HomebrewでMySQLをupgradeした時に実行しておくコマンド.
# MySQLWorkbenckがエラーになる.

$ brew upgrade mysql
$ mysql_upgrade -u USER_NAME -p
> Enter password:
> Checking if update is needed.
> Checking server version.
> Running queries to upgrade MySQL server.
> Checking system database.
> mysql.server restart
> ... (中略)
$ mysql.server restart

gulpでエラーが出たので対応した.

Gulp.js npm Node.js

# gulpでエラーが出たので対応した.

$ gulp
module.js:474
throw err;
^

Error: Cannot find module 'internal/fs'
at Function.Module._resolveFilename (module.js:472:15)
at Function.Module._load (module.js:420:25)
at Module.require (module.js:500:17)
at require (internal/module.js:20:19)
at evalmachine.:17:20
at Object. (/PATH/TO/graceful-fs/fs.js:11:1)
at Module._compile (module.js:573:32)
at Object.Module._extensions..js (module.js:582:10)
at Module.load (module.js:490:32)
at tryModuleLoad (module.js:450:

$ rm -rf node_modules
$ npm i

VirtualBoxが入っていなかったので,インストールした.

Server Vagrant VirtualBox

# VirtualBoxが入っていなかったので,インストールした.

$ vg up
> ... (中略)
> If you believe you already have a provider available, make sure it
> is properly installed and configured. You can see more details about
> why a particular provider isn't working by forcing usage with
> `vagrant up --provider=PROVIDER`, which should give you a more specific
> error message for that particular provider.

$ virtualbox
> -bash: virtualbox: command not found

# VirtualBoxをサイト(https://www.virtualbox.org/wiki/Downloads)からダウンロードする.

$ vagrant up
> ... (省略)